SSRS – WebForms Error 12019

Issue

We have some really long running queries in our SSRS SharePoint integrated mode environment. After a few minutes of processing, we would see the following error:

Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 12019

Interestingly, this issue only occurs when using IE. In Chrome, the report keeps running and works fine.

Solution

In our environment, we have an F5 BigIP as the load balancer in front of SharePoint. All we needed to do was set the Idle Timeout to 3600 (default was 300) on the TCP profile for the virtual server.


In other load balancing solutions, there are likely similar settings.

Advertisements

4 thoughts on “SSRS – WebForms Error 12019

  1. David

    We get this error through our Netscaler gateway version 11. I’ve tried IE 11, Chrome and firefox….Frustrating..

    Reply
    1. John

      HI David

      Did you ever get a solution to this.

      Strangely our users only get the problem with OWA through the netscaler when replying to emails. New emails work fine.

      Reply
  2. Vimal

    Thanks for posting this solution. Even i had the same issue and on increasing the TCP profile ideal timeout in load balance fixed the issue. I increased it to 1800 seconds and it worked.

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s