WSS 3.0: User’s email address that is populated on site collection creation

I had an interesting issue reported to me the other day.  One of the site administrators noticed that every time he created a new site collection (via self-service site creation), the email address that was populated in the new site collection user list (/_layouts/userdisp.aspx) was not his default SMTP address as specified in Exchange/AD.  Instead, it was one of his other SMTP email addresses (we have multiple domains, so each user has 5-10 SMTP addresses.)

For example:
Here are Joe’s email addresses:
joe@fabrikam.com <- default
joe@litwareinc.com

So, when Joe create a new site collection, the user list on the new site collection contains joe@litwareinc.com, instead of joe@fabrikam.com as you would expect.

Turns out that when you create a new site collection, WSS pulls your email address from whatever is specified on the web application’s root site.  At some point, his email address had been manually updated on the root site and therefore every new site was created with that email address. 

All we had to do was update the email address that was specified on the root site and all was well.  Of course, none of this would be an issue with MOSS, because the SSP handles profile synchronization with AD to keep user information current.  This was confirmed by Microsoft support to be ‘As Designed’.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s