‘Enable this form to be filled out by using a browser’ option disabled when publishing an InfoPath form to MOSS 2007

If you have ever run into the issue where you can’t publish an InfoPath form to a specific site because the ‘Enable this form to be filled out by using a browser’ option is disabled in the publishing wizard, here are a couple suggestions.

Example of option being disabled in the InfoPath publishing wizard:

Figure 1

Enterprise Features

Check to make sure that the “Office SharePoint Server Enterprise Site features” are enabled on the site that you are trying to publish the form to.

If it is already enabled, you will likely need to try the next option.

Re-enable the InfoPath Form Services feature on the site collection and site

Replace <SiteURI> with the sub-site URI
Replace <SiteCollectionURI> with the site collection URI

Run this on the central admin SharePoint server:

stsadm -o deactivatefeature -filename IPFSWebFeatures\feature.xml -force -url <SiteURI>

stsadm -o deactivatefeature -filename IPFSSiteFeatures\feature.xml -force -url <SiteCollectionURI>

stsadm -o activatefeature -filename IPFSSiteFeatures\feature.xml -force -url <SiteCollectionURI>

stsadm -o activatefeature -filename IPFSWebFeatures\feature.xml -force -url <SiteURI>

Note: if you are working with a site that is the root site in a site collection, <SiteCollectionURI> and <SiteURI> will be the same.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s